Issues loading Product Catalog via Manager Dashboard

Incident Report for GoTab

Resolved

This incident has now been resolved.
Posted Sep 01, 2026 - 20:32 EDT

Monitoring

Our team has implemented a fix regarding issues loading the Product Catalog. We will continue to monitor the situation for the time being.
Posted Sep 01, 2026 - 20:20 EDT

Identified

Our team determined the cause of the issue and a fix will be released imminently. The Product Catalog was negatively impacted by API issues directly from Quickbooks.
Posted Sep 01, 2026 - 18:43 EDT

Update

We are continuing to investigate this issue.
Posted Sep 01, 2026 - 17:35 EDT

Investigating

Our team are currently investigating reports of timeout errors when loading the Product Catalog via the Manager Dashboard.
Posted Sep 01, 2026 - 17:31 EDT
This incident affected: Infrastructure (Manager Dashboard).