Manager Dashboard Page Loading

Incident Report for GoTab

Resolved

Our engineering team has identified and deployed a fix for the issue affecting intermittent page loading issues in the manager dashboard.
Posted Jul 17, 2026 - 10:34 EDT

Investigating

Our team is actively investigating reports of intermittent page loading issues in the GoTab Manager Dashboard.
Posted Jul 17, 2026 - 10:12 EDT
This incident affected: Infrastructure (Manager Dashboard).