Platform Latency

Incident Report for GoTab

Resolved

Our engineering team has resolved the incident and verified that normal operations have been restored.
Posted Apr 18, 2026 - 20:32 EDT

Investigating

Our team is still actively investigating platform latency issues affecting orders not immediately updating in the KDS, slow POS response and CFDs having difficulty connecting to the POS.
Posted Apr 18, 2026 - 16:55 EDT
This incident affected: Infrastructure (Point of Sale (POS), Customer Facing Display (CFD), Kitchen Display System (KDS)).