Latency Impacting POS and Payment Terminals

Incident Report for GoTab

Resolved

This incident has been resolved.
Posted Jul 17, 2026 - 20:53 EDT

Monitoring

Our team has implemented a fix and will continue monitoring the results.
Posted Jul 17, 2026 - 18:50 EDT

Identified

App latency issue has been identified. Our team has implemented more resources to bolster performance.
Posted Jul 17, 2026 - 18:42 EDT

Investigating

We are investigating reports of degraded performance impacting POS and Payment Terminals
Posted Jul 17, 2026 - 18:16 EDT
This incident affected: Infrastructure (Point of Sale (POS), Customer Facing Display (CFD)).