System Latency

Incident Report for GoTab

Resolved

All system monitors are continuing to report health metrics within expected ranges.
Posted Feb 26, 2026 - 15:56 EST

Monitoring

We are observing a return to normal request latency levels after implementing mitigations.
Posted Feb 26, 2026 - 14:55 EST

Update

We have mitigated the immediate issues while our engineers continue investigating the root cause of the ongoing incident. Further updates will be published as details become available.
Posted Feb 26, 2026 - 14:31 EST

Investigating

We are currently investigating an issue with system latency that can affect POS loading, Kiosk Ordering and Manager Dashboard page loading.
Posted Feb 26, 2026 - 13:33 EST
This incident affected: Infrastructure (Point of Sale (POS), Kiosk, Manager Dashboard).