Adyen is reporting the incident has been resolved.
Posted Nov 14, 2024 - 11:05 EST
Monitoring
We are seeing a restoration of Adyen services and are monitoring updates from their engineering team.
Posted Nov 14, 2024 - 10:28 EST
Identified
Adyen reports they have identified the root cause of the issue and are actively working on a resolution.
Posted Nov 14, 2024 - 10:15 EST
Investigating
We are aware of an ongoing incident with Adyen payments that is causing delays and timeouts. Adyen's engineering team is currently investigating. The latest status updates are posted on https://status.adyen.com/
Posted Nov 14, 2024 - 10:04 EST
This incident affected: Payments (Card-Present Payment System).