Platform Latency

Incident Report for GoTab

Resolved

This incident has been resolved.
Posted May 08, 2026 - 21:13 EDT

Update

We are continuing to monitor for any further issues.
Posted May 08, 2026 - 21:11 EDT

Monitoring

We've implemented mitigation for recent issues where some customers were experiencing delays with POS and KDS performance. We're seeing improvements and are closely monitoring the situation.

For real-time updates, please visit status.gotab.io.
Posted May 08, 2026 - 20:31 EDT

Investigating

We are currently investigating reported latency issues impacting POS and KDS displays.
Posted May 08, 2026 - 20:27 EDT
This incident affected: Infrastructure (Point of Sale (POS), Kitchen Display System (KDS)) and Payments (Card-Present Payment System).